JapaneseCrossword

Программа предназначена для создания, а также решения японских кроссвордов. С помощью её легко нарисовать свой кроссворд или быстро решить газетный или журнальный. Программа использует уникальный алгоритм, который решает любые кроссворды (если они решаемы).

Программа позволяет, как пользователю решать кроссворд вручную, так и автоматически с помощью алгоритма.

Разделы справки

  • Создание кроссворда
  • Проверка на решаемость
  • Решение кроссворда
  • Оптимизация
  • Сохранение
  • Импорт из текстового файла
  • Импорт из BMP-файла
  • Печать
  • Копирование
  • Масштабирование
  • Регистрация


Создание кроссворда.

Для создания нового кроссворда нужно выбрать пункт меню File/New ( [image]). В появившемся диалоге указать размеры кроссворда (ширину и высоту).

Появиться сетка кроссворда. По ней и надо рисовать картинку кроссворда. Для рисования используются следующие комбинации клавиш :

Left_Button_Mouse | Закрасить клетку сетки в синий цвет.
Right_Button_Mouse | Закрасить клетку сетки в белый цвет.
CTRL+Left_Button_Mouse | Поставить в клетке крестик (при ручном решении).
Shift+Left_Button_Mouse | Закрасить клетки сетки, попавшие в прямоугольник выделения, в синий цвет.
Shift+Right_Button_Mouse | Закрасить клетки сетки, попавшие в прямоугольник выделения, в белый цвет.
Shift+CTRL+Left_Button_Mouse | Поставить в клетки сетки, попавшие в прямоугольник выделения, крестики (при ручном решении).
ESC (удерживая) | Остановить решение кроссворда.

После того как рисунок нарисован, нужно выбрать пункт меню Create/Generate crossword ( [image]). Это приведёт к тому, что кроссворд рассчитается, и слева и сверху появятся клетки с числами. На этом создание кроссворда закончено. Его можно проверить на решаемость, а также сохранить в одном из поддерживаемых форматов или скопировать через буфер обмена для дальнейшей вставки в другие программы.


Проверка на решаемость.

Если вы нарисовали кроссворд сами, то какой бы он красив не был, есть вероятность того, что он не решиться (есть много вариантов решения), его надо проверить на решаемость. Для этого его достаточно решить.Если бы в программе использовался алгоритм перебора, то таких бы проблем не было – программа перебрала б все варианты и остановилась на первом удавшемся. Так как программа JapaneseCrossword не использует метод перебора, а решает по алгоритму схожему с человеческим алгоритмом, то она позволяет отследить и это.


Решение кроссворда.

Для того чтобы запустить программу на решение необходимо выбрать пункт меню Create/Solve ( [image]). Программа начнёт решение, во время которого можно делать с кроссвордом всё что угодно (масштабировать, печатать, копировать). Однако, чтобы внести изменения, необходимо остановить расчёт, внести изменения и потом запустить опять. Остановить решение можно выбором пункта меню Create/Stop Solving ( [image]) или нажав клавишу ESC. Информация о ходе решения кроссворда отображается в строке состояния, в виде индикатора выполнения. После каждого прохода по кроссворду программа обновляет картинку (виден ход решения). Отображение каждого изменения, было отвергнуто для ускорения решения. После завершения решения программа выдаёт окошко с информацией о затраченном времени на решение, а также удачном или неудачном результате.

При неудачном результате и включённой оптимизации программа рекомендует либо уменьшить коэффициент оптимизации, либо вообще отказаться от неё. Подробнее об оптимизации смотрите раздел Оптимизация.

Программа учитывает состояние кроссворда на момент запуска решения. То есть если некоторые клетки кроссворда были закрашены или содержали крестики, то это будет учтено программой. Для того чтобы решить кроссворд «с нуля» необходимо очистить сетку, для этого нужно выбрать пункт меню Create/Clear grid ( [image]).


Оптимизация.

Иногда попадаются кроссворды, которые очень утомительно решать, когда цепляешься за каждую клеточку, и результат получаешь только через несколько часов. Например, когда строчка кроссворда содержит 40 клеточек, а значения для неё 1,2,2,1,1,1,1,2,1, такую строчку можно определить только когда будет разгадана львиная доля кроссворда. Если же с самого начала попытаться взяться за её разгадывание, то это будет только потеря времени. Для обхода таких ситуаций и была введена в программу оптимизация.

Для вызова данного диалога необходимо выбрать пункт меню Setting/Optimization ( [image]) В диалоге можно либо вообще отключить оптимизацию, либо изменить её коэффициент. При полностью отключенной оптимизации программа не откладывает на потом решение приведённых выше строк и может надолго остановиться, решая такую строчку. Чем больше коэффициент оптимизации, тем меньше времени программа тратит на решение таких строк, а откладывает их на потом, но при этом выполняет больше проходов по полю кроссворда. В некоторых случаях программа не может решить кроссворд, так как установлен слишком маленький коэффициент оптимизации. В таком случае нужно уменьшить его. Автор не рекомендует отказываться от оптимизации для больших кроссвордов. Тестирование показало, что для некоторых кроссвордов увеличение коэффициента оптимизации приводит к увеличению скорости решения, а для некоторых к уменьшению (всё зависит от сложности кроссворда).


Сохранение.

Сохранить кроссворд на любом этапе его создания или решения. Для этого нужно выбрать пункт меню File/Save As…Программа поддерживает следующие форматы:
Crossword file (*.jcw) | Файл, в котором в бинарном виде храниться кроссворд. Родной формат программы JapaneseCrossword.
Text file (*.txt) | Текстовый файл, позволяет в дальнейшем импортироваться в программу. В нём храниться кроссворд в читабельном виде.
Bitmap file (*.bmp) | Файл рисунка. Кроссворд храниться как монохромный рисунок, в котором каждый пиксель соответствует клетке кроссворда.
Windows Metafile (*.emf) | Метафайл, который понимает множество программ (Word, Excel, CorelDraw и т.д.)


Импорт из текстового файла.

Для решения кроссвордов напечатанных в периодических изданиях (газеты, журналы) существует импорт из текстового файла. Для этого необходимо создать сам файл, а затем его импортировать в программу – пункт меню File/Import/Import from txt ( [image]).

Структура файла должна подчиняться следующим правилам:

  1. Сначала перечисляются строки слева, затем колонки сверху.
  2. Начинается перечисление строк со слова Left, колонок со слова Top.
  3. Числа строк записываются слева направо, числа колонок сверху вниз.
  4. Каждая новая строка или колонка начинается с новой строки.
  5. Разделитель между числами – запятая.
  6. Если строка пустая должен стоять ноль «0».

Например, вот такой кроссворд:

будет в виде текстового файла таким

Left
3
1,1
1,1
1
1,1
1,1
3
Top
1,1
1,1,1,1
1,1,1
1,1,1,1
1,1


Импорт из BMP-файла.

Для облегчения труда составителям кроссвордов в программу введён импорт кроссвордов из BMP-файлов. Для этого необходимо выбрать пункт меню File/Import/Import from bmp ( [image]).

На BMP-файл накладываются следующие ограничения:

  1. Он должен быть монохромным (в палитре цветов только 2 цвета).
  2. Он должен быть без компрессии.


Печать.

Вывод на печать осуществляется по стандартной схеме с возможностью предварительного просмотра. Любой кроссворд будет печататься только на одну страницу. Если кроссворд маленький, то будет печататься с размером клетки 5 мм. Если очень большой - сожмётся до размеров страницы. За печать отвечают 3 пункта меню. File/Print setup… - вызывает диалог «Настройка печати». File/Print Preview – вызывает окно предварительного просмотра. File/Print… ( [image]) - вызывает диалог «Печать».


Копирование.

Для дальнейшего использования в документах офис-приложений можно копировать кроссворд в буфер обмена в формате метафайла. Данный формат более предпочтителен, чем BMP, из-за того, что метафайл можно масштабировать без потери качества, чего нельзя сказать о формате BMP. Для копирования необходимо выбрать пункт меню Edit/Copy ( [image]).


Масштабирование.

В некоторых случаях необходимо увеличить изображение или уменьшить. Для таких случаев в программе есть инструмент масштабирования. Чтобы увеличить изображение нужно выбрать пункт меню Change/Zoom in ( [image]), а чтобы уменьшить Change/Zoom out ( [image]).


Регистрация.

Данная программа является Shareware. Чтобы получить полную версию необходимо зарегистрироваться. Стоимость одной лицензии 15 USD. На данный момент принимаются платежи через систему WebMoney на кошелёк Z195985039308, а также почтовые переводы. Чтобы не возникло проблем с оплатой, предварительно свяжитесь с автором по электронной почте, напишите письмо заявку, указав в ней ваше имя, фамилию, способ оплаты, а также адрес электронной почты, по которому можно выслать полную версию программы с логином и паролем. После того, как вы получите программу, логин и пароль, нужно выбрать пункт меню Help/Registration и в появившемся диалоге заполнить необходимые поля.

Информацию о системе WebMoney можете посмотреть здесь http://www.webmoney.ru

Электронный адрес автора Rostislav@nuvse.com
Сайт программы http://CocoJumbo.narod.ru/programs/JapaneseCrossword/index.html

Вниманию взломщиков!!!

Чтобы облегчить вам жизнь, сообщаю – Не пытайтесь взломать Shareware версию программы, это невозможно, так как в ней просто отсутствует код программы, который есть в полной версии.